Computer Security
[EN] securityvulns.ru no-pyccku


CVECVE-2015-0231
StatusCandidate
DescriptionUse-after-free vulnerability in the process_nested_data function in ext/standard/var_unserializer.re in PHP before 5.4.37, 5.5.x before 5.5.21, and 5.6.x before 5.6.5 allows remote attackers to execute arbitrary code via a crafted unserialize call that leverages improper handling of duplicate numerical keys within the serialized properties of an object.  NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-8142.
Severity
High
CVSS score7,5
CVSS vector(AV:N/AC:L/Au:N/C:P/I:P/A:P)
PhaseAssigned (09.10.2015)
NVD:http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-0231
ReferencesDEBIAN : DSA-3195
 CONFIRM : http://advisories.mageia.org/MGASA-2015-0040.html
 CONFIRM : http://www.php.net/ChangeLog-5.php
 CONFIRM : https://bugs.php.net/bug.php?id=68710
 CONFIRM : https://bugzilla.redhat.com/show_bug.cgi?id=1185397
 CONFIRM : https://github.com/php/php-src/commit/b585a3aed788...
 MANDRIVA : MDVSA-2015:032
 MANDRIVA : MDVSA-2015:079
 SUSE : openSUSE-SU-2015:0325
 SUSE : SUSE-SU-2015:0365
SecurityVulns:PHP multiple security vulnerabilities
 PHP multiple security vulnerabilities
 Apple Mac OS X / Mac EFI / OS X Server multiple security vulnerabilities
About | Terms of use | Privacy Policy
© SecurityVulns, 3APA3A, Vladimir Dubrovin
Nizhny Novgorod