Computer Security
[EN] securityvulns.ru no-pyccku


CVECVE-2015-1793
StatusCandidate
DescriptionThe X509_verify_cert function in crypto/x509/x509_vfy.c in OpenSSL 1.0.1n, 1.0.1o, 1.0.2b, and 1.0.2c does not properly process X.509 Basic Constraints cA values during identification of alternative certificate chains, which allows remote attackers to spoof a Certification Authority role and trigger unintended certificate verifications via a valid leaf certificate.
Severity
Medium
CVSS score6,4
CVSS vector(AV:N/AC:L/Au:N/C:P/I:P/A:N)
PhaseAssigned (25.08.2015)
NVD:http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-1793
ReferencesHP : HPSBUX03388
 CONFIRM : http://openssl.org/news/secadv_20150709.txt
 CONFIRM : https://git.openssl.org/?p=openssl.git;a=commit;h=...
 HP : SSRT102180
SecurityVulns:OpenSSL restrictions bypass
 Oracle / Sun / PeopleSoft / MySQL multiple security vulnerabilities
About | Terms of use | Privacy Policy
© SecurityVulns, 3APA3A, Vladimir Dubrovin
Nizhny Novgorod