Computer Security
[EN] securityvulns.ru no-pyccku


CVECVE-2015-2331
StatusCandidate
DescriptionInteger overflow in the _zip_cdir_new function in zip_dirent.c in libzip 0.11.2 and earlier, as used in the ZIP extension in PHP before 5.4.39, 5.5.x before 5.5.23, and 5.6.x before 5.6.7 and other products, allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a ZIP archive that contains many entries, leading to a heap-based buffer overflow.
Severity
High
CVSS score7,5
CVSS vector(AV:N/AC:L/Au:N/C:P/I:P/A:P)
PhaseAssigned (09.10.2015)
NVD:http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-2331
ReferencesSECTRACK : 1031985
 DEBIAN : DSA-3198
 FEDORA : FEDORA-2015-4559
 FEDORA : FEDORA-2015-4565
 FEDORA : FEDORA-2015-4669
 CONFIRM : http://git.php.net/?p=php-src.git;a=commit;h=ef8fc...
 CONFIRM : http://hg.nih.at/libzip/rev/9f11d54f692e
 CONFIRM : http://php.net/ChangeLog-5.php
 CONFIRM : https://bugs.php.net/bug.php?id=69253
 MANDRIVA : MDVSA-2015:079
 SUSE : openSUSE-SU-2015:0615
 SUSE : openSUSE-SU-2015:0644
SecurityVulns:PHP multiple security vulnerabilities
 Apple Mac OS X / Mac EFI / OS X Server multiple security vulnerabilities
About | Terms of use | Privacy Policy
© SecurityVulns, 3APA3A, Vladimir Dubrovin
Nizhny Novgorod