Computer Security
[EN] securityvulns.ru no-pyccku


CVECVE-2015-2348
StatusCandidate
DescriptionThe move_uploaded_file implementation in ext/standard/basic_functions.c in PHP before 5.4.39, 5.5.x before 5.5.23, and 5.6.x before 5.6.7 truncates a pathname upon encountering a \x00 character, which allows remote attackers to bypass intended extension restrictions and create files with unexpected names via a crafted second argument.  NOTE: this vulnerability exists because of an incomplete fix for CVE-2006-7243.
Severity
Medium
CVSS score5
CVSS vector(AV:N/AC:L/Au:N/C:N/I:P/A:N)
PhaseAssigned (09.10.2015)
NVD:http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-2348
ReferencesCONFIRM : http://git.php.net/?p=php-src.git;a=commit;h=1291d...
 CONFIRM : http://php.net/ChangeLog-5.php
 CONFIRM : https://bugs.php.net/bug.php?id=69207
 SUSE : openSUSE-SU-2015:0684
SecurityVulns:Apple Mac OS X / Mac EFI / OS X Server multiple security vulnerabilities
About | Terms of use | Privacy Policy
© SecurityVulns, 3APA3A, Vladimir Dubrovin
Nizhny Novgorod