Computer Security
[EN] securityvulns.ru no-pyccku


CVECVE-2015-3414
StatusCandidate
DescriptionSQLite before 3.8.9 does not properly implement the dequoting of collation-sequence names, which allows context-dependent attackers to cause a denial of service (uninitialized memory access and application crash) or possibly have unspecified other impact via a crafted COLLATE clause, as demonstrated by COLLATE"""""""" at the end of a SELECT statement.
Severity
High
CVSS score7,5
CVSS vector(AV:N/AC:L/Au:N/C:P/I:P/A:P)
PhaseAssigned (24.04.2015)
NVD:http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-3414
ReferencesFULLDISC : 20150414 several issues in SQLite (+ catching up on several other bugs)
 APPLE : APPLE-SA-2015-09-21-1
 APPLE : APPLE-SA-2015-09-30-3
 DEBIAN : DSA-3252
 CONFIRM : https://support.apple.com/HT205213
 CONFIRM : https://support.apple.com/HT205267
 CONFIRM : https://www.sqlite.org/src/info/eddc05e7bb31fae74d...
 MANDRIVA : MDVSA-2015:217
 UBUNTU : USN-2698-1
SecurityVulns:SQLite multiple security vulnerabilities
 Apple Mac OS X / Mac EFI / OS X Server multiple security vulnerabilities
About | Terms of use | Privacy Policy
© SecurityVulns, 3APA3A, Vladimir Dubrovin
Nizhny Novgorod