Computer Security
[EN] securityvulns.ru no-pyccku


OpenBSD vga privilege escalation
updated since 05.01.2007
Published:08.01.2007
Source:
SecurityVulns ID:7004
Type:local
Threat Level:
7/10
Description:vga_ioctl() syscall allows code execution in kernel.
Affected:OPENBSD : OpenBSD 3.9
 OPENBSD : OpenBSD 4.0
CVE:CVE-2007-0085 (Unspecified vulnerability in sys/dev/pci/vga_pci.c in the VGA graphics driver for wscons in OpenBSD 3.9 and 4.0, when the kernel is compiled with the PCIAGP option and a non-AGP device is being used, allows local users to gain privileges via unspecified vectors, possibly related to agp_ioctl NULL pointer reference.)
Original documentdocumentSECUNIA, [SA23608] OpenBSD "vga" Privilege Escalation Vulnerability (05.01.2007)
Files:OpenBSD 3.x-4.0 vga_ioctl() root exploit

About | Terms of use | Privacy Policy
© SecurityVulns, 3APA3A, Vladimir Dubrovin
Nizhny Novgorod