Computer Security
[EN] securityvulns.ru no-pyccku


Rumpus FTP server multiple security vulnerabilities
Published:21.01.2007
Source:
SecurityVulns ID:7082
Type:remote
Threat Level:
6/10
Description:Shell characters problems, buffer overflows, weaklpermissions.
Affected:RUMPUS : Rumpus 5.1
CVE:CVE-2007-0367 (Rumpus 5.1 and earlier has weak permissions for certain files and directories under /usr/local/Rumpus, including the configuration file, which allows local users to have an unknown impact by creating, modifying, or deleting files.)
 CVE-2007-0366 (Untrusted search path vulnerability in Rumpus 5.1 and earlier allows local users to gain privileges via a modified PATH that points to a malicious ipfw program.)
 CVE-2007-0019 (Multiple heap-based buffer overflows in rumpusd in Rumpus 5.1 and earlier (1) allow remote authenticated users to execute arbitrary code via a long LIST command and other unspecified requests to the FTP service, and (2) allow remote attackers to execute arbitrary code via unspecified requests to the HTTP service.)
Original documentdocumentMOAB, MOAB-18-01-2007: Rumpus Multiple Vulnerabilities (21.01.2007)
Files:Proof of concept for issues described in MOAB-18-01-2007

About | Terms of use | Privacy Policy
© SecurityVulns, 3APA3A, Vladimir Dubrovin
Nizhny Novgorod