Computer Security
[EN] securityvulns.ru no-pyccku


OpenLDAP installation symbolic links vulnerability
Published:24.01.2007
Source:
SecurityVulns ID:7094
Type:remote
Threat Level:
4/10
Description:gencert.sh installation script insecure tempoary files creation.
Affected:OPENLDAP : OpenLDAP 2.2
 OPENLDAP : OpenLDAP 2.1
 OPENLDAP : OpenLDAP 2.3
CVE:CVE-2007-0476 (The gencert.sh script, when installing OpenLDAP before 2.1.30-r10, 2.2.x before 2.2.28-r7, and 2.3.x before 2.3.30-r2 as an ebuild in Gentoo Linux, does not create temporary directories in /tmp securely during emerge, which allows local users to overwrite arbitrary files via a symlink attack.)
Original documentdocumentGENTOO, [ GLSA 200701-19 ] OpenLDAP: Insecure usage of /tmp during installation (24.01.2007)

About | Terms of use | Privacy Policy
© SecurityVulns, 3APA3A, Vladimir Dubrovin
Nizhny Novgorod