Computer Security
[EN] securityvulns.ru no-pyccku


Related information

  Дырка в Windows 2000 (Network DDE Agent privilege elevation)

  REVISION: @stake Advisory Notification: NetDDE Message Vulnerability (A020501-1)

  @stake Advisory Notification: NetDDE Message Vulnerability (A020501-1)

From:MICROSOFT <secure_(at)_microsoft.com>
Date:06.02.2001
Subject:Security Bulletin MS01-007

- ----------------------------------------------------------------------
Title:      Patch Available for "Network DDE Agent Request"
           Vulnerability
Date:       05 February 2001
Software:   Windows 2000
Impact:     Privilege elevation
Bulletin:   MS01-007

Microsoft encourages customers to review the Security Bulletin at:
http://www.microsoft.com/technet/security/bulletin/MS01-007.asp.
- ----------------------------------------------------------------------

Issue:
======
Network Dynamic Data Exchange (DDE) is a technology that enables
applications on different Windows computers to dynamically share
data. This sharing is effected via communications channels called
trusted shares, which are managed by a service called the Network DDE
Agent. By design, processes on the local machine can levy requests
upon the Network DDE Agent, including ones that indicate what
application should be run in conjunction with a particular trusted
share. However, a vulnerability exists because, in Windows 2000, the
Network DDE Agent runs using the Local System security context and
processes all requests using this context, rather than that of the
user. This would give an attacker an opportunity to cause the Network
DDE Agent to run code of her choice in Local System context, as a
means of gaining complete control over the local machine.

Microsoft recommends that customers using Windows 2000 workstations
or who allow unprivileged users to run code on Windows 2000 servers
apply the patch immediately. In addition, customers operating Windows
2000 web servers should consider applying the patch to those machines
as well, as a precautionary measure. If an attacker were able to gain
the ability to run code in a restricted context on a web server via
another vulnerability, this vulnerability would provide a way to
immediately elevate her privileges and cause broader damage.

Mitigating Factors:
====================
- The vulnerability would not affect terminal servers unless the
  attacker could log on at the console.  Best practices recommend
  against this.
- Servers could only be affected if the attacker were given the
  ability to load a program of her choice onto the machine and
  execute it locally.  Best practices recommend against this.
- Workstations, the machines primarily at risk, typically would
  not provide a way for the attacker to use control over the
  local machine to gain domain-wide privileges

Patch Availability:
===================
- A patch is available to fix this vulnerability. Please read the
  Security Bulletin
  http://www.microsoft.com/technet/security/bulletin/ms01-007.asp
  for information on obtaining this patch.

Acknowledgment:
===============
- Dildog of @Stake (http://www.atstake.com)

- ---------------------------------------------------------------------

THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED
"AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL
WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT
SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY
DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL,
CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF
MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE
POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION
OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO
THE FOREGOING LIMITATION MAY NOT APPLY.

About | Terms of use | Privacy Policy
© SecurityVulns, 3APA3A, Vladimir Dubrovin
Nizhny Novgorod