Computer Security
[EN] no-pyccku

Related information

  D-Link DCS-2103 security vulnerabilities

  AoF ana CSRF vulnerabilities in D-Link DCS-2103

  BF and XSS vulnerabilities in D-Link DCS-2103

  Vulnerabilities in D-Link DCS-2103

From:MustLive <mustlive_(at)>
Subject:CSRF and XSS vulnerabilities in D-Link DCS-2103

Hello 3APA3A!

There are Cross-Site Request Forgery and Cross-Site Scripting vulnerabilities in D-Link DCS-2103 (IP camera).

Affected products:

Vulnerable is the next model: D-Link DCS-2103, Firmware 1.0.0. Version 1.20 and previous versions also must be vulnerable.


Cross-Site Request Forgery (WASC-09):

CSRF vulnerabilities in all sections of admin panel. E.g. change DEVICE SETTING (parameters: IP camera Name, Enable OSD, Label, Show time).


Cross-Site Scripting (WASC-08):


This is persistent XSS. The code will execute at pages: maintenance.htm, maintenance_device.htm, maintenance_backup_restore.htm, maintenance_firmware_upgrade.htm.


2014.08.01 - announced at my site about previous vulnerabilities in DCS-2103.
2014.11.14-2014.12.13 - conversation with D-Link about vulnerabilities in DCS-2103.
2014.11.27 - announced at my site about new vulnerabilities in DCS-2103.
2015.07.23 - disclosed at my site (

I found this and other web cameras during summer 2014 to watch terrorists activities in Donetsk and Lugansks regions of Ukraine and also in Russia (

Best wishes & regards,
Administrator of Websecurity web site

About | Terms of use | Privacy Policy
© SecurityVulns, 3APA3A, Vladimir Dubrovin
Nizhny Novgorod