Computer Security
[EN] securityvulns.ru no-pyccku


AirDroid multiple security vulnerabilities
Published:16.07.2012
Source:
SecurityVulns ID:12478
Type:remote
Threat Level:
5/10
Description:Multiple cryptography weaknesses.
Affected:AIRDROID : AirDroid 1.0
CVE:CVE-2012-3888 (The login implementation in AirDroid 1.0.4 beta allows remote attackers to bypass a multiple-login protection mechanism by modifying a pass value within JSON data.)
 CVE-2012-3887 (AirDroid before 1.0.7 beta uses a cleartext base64 format for data transfer that is documented as an "Encrypted Transmission" feature, which allows remote attackers to obtain sensitive information by sniffing the local wireless network, as demonstrated by the SMS message content sent to the sdctl/sms/send/single/ URI.)
 CVE-2012-3886 (AirDroid 1.0.4 beta uses the MD5 algorithm for values in the checklogin key parameter and 7bb cookie, which makes it easier for remote attackers to obtain cleartext data by sniffing the local wireless network and then conducting a (1) brute-force attack or (2) rainbow-table attack.)
 CVE-2012-3885 (The default configuration of AirDroid 1.0.4 beta uses a four-character alphanumeric password, which makes it easier for remote attackers to obtain access via a brute-force attack.)
 CVE-2012-3884 (AirDroid 1.0.4 beta implements authentication through direct transmission of a password hash over HTTP, which makes it easier for remote attackers to obtain access by sniffing the local wireless network and then replaying the authentication data.)
Original documentdocumentKathrin Schaberle, security advisory: AirDroid 1.0.4 beta (16.07.2012)

About | Terms of use | Privacy Policy
© SecurityVulns, 3APA3A, Vladimir Dubrovin
Nizhny Novgorod