Computer Security
[EN] securityvulns.ru no-pyccku


Apache Tomcat crossite scripting
Published:14.06.2007
Source:
SecurityVulns ID:7815
Type:remote
Threat Level:
5/10
Description:Crossite scripting with Manager / Host Manager or JSP pages examples.
Affected:APACHE : Tomcat 4.0
 APACHE : Tomcat 4.1
 APACHE : Tomcat 5.0
 APACHE : Tomcat 5.5
 APACHE : Tomcat 6.0
CVE:CVE-2007-2450 (Multiple cross-site scripting (XSS) vulnerabilities in the (1) Manager and (2) Host Manager web applications in Apache Tomcat 4.0.0 through 4.0.6, 4.1.0 through 4.1.36, 5.0.0 through 5.0.30, 5.5.0 through 5.5.24, and 6.0.0 through 6.0.13 allow remote authenticated users to inject arbitrary web script or HTML via a parameter name to manager/html/upload, and other unspecified vectors.)
 CVE-2007-2449 (Multiple cross-site scripting (XSS) vulnerabilities in certain JSP files in the examples web application in Apache Tomcat 4.0.0 through 4.0.6, 4.1.0 through 4.1.36, 5.0.0 through 5.0.30, 5.5.0 through 5.5.24, and 6.0.0 through 6.0.13 allow remote attackers to inject arbitrary web script or HTML via the portion of the URI after the ';' character, as demonstrated by a URI containing a "snp/snoop.jsp;" sequence.)
Original documentdocumentAPACHE, [Full-disclosure] [CVE-2007-2450]: Apache Tomcat XSS vulnerability in Manager (14.06.2007)
 documentAPACHE, [Full-disclosure] [CVE-2007-2449] Apache Tomcat XSS vulnerabilities in the JSP examples (14.06.2007)

About | Terms of use | Privacy Policy
© SecurityVulns, 3APA3A, Vladimir Dubrovin
Nizhny Novgorod