Computer Security
[EN] securityvulns.ru no-pyccku


Apple Safari / Webkit multiple security vulnerabilities
Published:05.07.2015
Source:
SecurityVulns ID:14559
Type:library
Threat Level:
7/10
Description:Multiple memory corruptions.
Affected:APPLE : Safari 8.0
 APPLE : iTunes 12.1
 APPLE : Safari 7.1
 APPLE : Safari 6.2
CVE:CVE-2015-3727 (WebKit in Apple Safari before 6.2.7, 7.x before 7.1.7, and 8.x before 8.0.7, as used in Apple iOS before 8.4 and other products, does not properly restrict rename operations on WebSQL tables, which allows remote attackers to access an arbitrary web site's database via a crafted web site.)
 CVE-2015-3660 (Cross-site scripting (XSS) vulnerability in the PDF functionality in WebKit in Apple Safari before 6.2.7, 7.x before 7.1.7, and 8.x before 8.0.7 allows remote attackers to inject arbitrary web script or HTML via a crafted URL in embedded PDF content.)
 CVE-2015-3659 (The SQLite authorizer in the Storage functionality in WebKit in Apple Safari before 6.2.7, 7.x before 7.1.7, and 8.x before 8.0.7, as used in Apple iOS before 8.4 and other products, does not properly restrict access to SQL functions, which allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via a crafted web site.)
 CVE-2015-3658 (The Page Loading functionality in WebKit in Apple Safari before 6.2.7, 7.x before 7.1.7, and 8.x before 8.0.7, as used in Apple iOS before 8.4 and other products, does not properly consider redirects during decisions about sending an Origin header, which makes it easier for remote attackers to bypass CSRF protection mechanisms via a crafted web site.)
Original documentdocumentAPPLE, APPLE-SA-2015-06-30-6 iTunes 12.2 (05.07.2015)
 documentAPPLE, APPLE-SA-2015-06-30-4 Safari 8.0.7, Safari 7.1.7, and Safari 6.2.7 (05.07.2015)

About | Terms of use | Privacy Policy
© SecurityVulns, 3APA3A, Vladimir Dubrovin
Nizhny Novgorod