Computer Security
[EN] securityvulns.ru no-pyccku


Citrix Access Gateway plugin security vulnerabilities
Published:03.09.2012
Source:
SecurityVulns ID:12569
Type:client
Threat Level:
5/10
Description:Buffer overflow, integer overflow.
Affected:CITRIX : Access Gateway Plug-in for Windows 9.3
CVE:CVE-2011-2593 (Integer overflow in the StartEpa method in the nsepacom ActiveX control (nsepa.exe) in Citrix Access Gateway Enterprise Edition Plug-in for Windows 9.x before 9.3-57.5 and 10.0 before 10.0-69.4 allows remote attackers to execute arbitrary code via a crafted Content-Length HTTP header, which triggers a heap-based buffer overflow.)
 CVE-2011-2592 (Heap-based buffer overflow in the StartEpa method in the nsepacom ActiveX control (nsepa.exe) in Citrix Access Gateway Enterprise Edition Plug-in for Windows 9.x before 9.3-57.5 and 10.0 before 10.0-69.4 allows remote attackers to execute arbitrary code via a long CSEC HTTP response header.)
Original documentdocumentSECUNIA, Secunia Research: Citrix Access Gateway Plug-in for Windows nsepacom ActiveX Control Integer Overflow (03.09.2012)
 documentSECUNIA, Secunia Research: Citrix Access Gateway Plug-in for Windows nsepacom ActiveX Control Buffer Overflow (03.09.2012)

About | Terms of use | Privacy Policy
© SecurityVulns, 3APA3A, Vladimir Dubrovin
Nizhny Novgorod