Computer Security
[EN] securityvulns.ru no-pyccku


CoreHTTP Web server buffer overflow
Published:08.12.2009
Source:
SecurityVulns ID:10448
Type:remote
Threat Level:
5/10
Description:Off-by-one buffer overflow on request method handling.
Affected:COREHTTP : CoreHTTP 0.5
CVE:CVE-2009-3586 (Off-by-one error in src/http.c in CoreHTTP 0.5.3.1 and earlier allows remote attackers to cause a denial of service or possibly execute arbitrary code via an HTTP request with a long first line that triggers a buffer overflow. NOTE: this vulnerability reportedly exists because of an incorrect fix for CVE-2007-4060.)
Original documentdocumentPatroklos Argyroudis, CVE-2009-3586: CoreHTTP web server off-by-one buffer overflow vulnerability (08.12.2009)

About | Terms of use | Privacy Policy
© SecurityVulns, 3APA3A, Vladimir Dubrovin
Nizhny Novgorod