Computer Security
[EN] securityvulns.ru no-pyccku


Firebird database server buffer overflow
Published:02.07.2007
Source:
SecurityVulns ID:7876
Type:remote
Threat Level:
8/10
Description:Buffer overflow on database connect request processing.
Affected:FIREBIRD : Firebird SQL 2.0
CVE:CVE-2007-3181 (Buffer overflow in fbserver.exe in Firebird SQL 2 before 2.0.1 allows remote attackers to execute arbitrary code via a large p_cnct_count value in a p_cnct structure in a connect (0x01) request to port 3050/tcp, related to "an InterBase version of gds32.dll.")
Original documentdocumentGENTOO, [Full-disclosure] [ GLSA 200707-01 ] Firebird: Buffer overflow (02.07.2007)

About | Terms of use | Privacy Policy
© SecurityVulns, 3APA3A, Vladimir Dubrovin
Nizhny Novgorod