Computer Security
[EN] securityvulns.ru no-pyccku


imlib2 library buffer overflow
Published:23.04.2010
Source:
SecurityVulns ID:10786
Type:library
Threat Level:
6/10
Description:Heap buffer overflow in IMAGE_DIMENSIONS_OK().
Affected:IMLIB2 : imlib2 1.4
CVE:CVE-2010-0991 (Multiple heap-based buffer overflows in imlib2 1.4.3 allow context-dependent attackers to execute arbitrary code via a crafted (1) ARGB, (2) XPM, or (3) BMP file, related to the IMAGE_DIMENSIONS_OK macro in lib/image.h.)
Original documentdocumentSECUNIA, Secunia Research: imlib2 "IMAGE_DIMENSIONS_OK()" Logic Error (23.04.2010)

About | Terms of use | Privacy Policy
© SecurityVulns, 3APA3A, Vladimir Dubrovin
Nizhny Novgorod