Computer Security
[EN] securityvulns.ru no-pyccku


Linux kernel JFFS2 filesystem permissions vulnerability
Published:28.09.2007
Source:
SecurityVulns ID:8196
Type:local
Threat Level:
5/10
Description:New permissions are not saved to media, cause the use of older permissions on media remount.
Affected:LINUX : kernel 2.6
CVE:CVE-2007-4849 (JFFS2, as used on One Laptop Per Child (OLPC) build 542 and possibly other Linux systems, when POSIX ACL support is enabled, does not properly store permissions during (1) inode creation or (2) ACL setting, which might allow local users to access restricted files or directories after a remount of a filesystem, related to "legacy modes" and an inconsistency between dentry permissions and inode permissions.)
Original documentdocumentDEBIAN, [SECURITY] [DSA 1378-1] New Linux 2.6.18 packages fix several vulnerabilities (28.09.2007)

About | Terms of use | Privacy Policy
© SecurityVulns, 3APA3A, Vladimir Dubrovin
Nizhny Novgorod