Computer Security
[EN] securityvulns.ru no-pyccku


Mltiple MIT Kerberos security vulnerabilities
updated since 04.04.2007
Published:11.04.2007
Source:
SecurityVulns ID:7527
Type:remote
Threat Level:
9/10
Description:telnet daemon arbitrary user logon without password, krb5_klog_syslog() buffer overflow, double free() vulnerability.
Affected:MIT : krb5 1.6
CVE:CVE-2007-1216 (Double-free vulnerability in the GSS-API library (lib/gssapi/krb5/k5unseal.c), as used by the Kerberos administration daemon (kadmind) in MIT krb5 before 1.6.1, when used with the authentication method provided by the RPCSEC_GSS RPC library, allows remote authenticated users to execute arbitrary code and modify the Kerberos key database via a message with an "an invalid direction encoding".)
 CVE-2007-0957 (Stack-based buffer overflow in the krb5_klog_syslog function in the kadm5 library, as used by the Kerberos administration daemon (kadmind) and Key Distribution Center (KDC), in MIT krb5 before 1.6.1 allows remote authenticated users to execute arbitrary code and modify the Kerberos key database via crafted arguments, possibly involving certain format string specifiers.)
 CVE-2007-0956 (The telnet daemon (telnetd) in MIT krb5 before 1.6.1 allows remote attackers to bypass authentication and gain system access via a username beginning with a '-' character, a similar issue to CVE-2007-0882.)
Original documentdocumentc0ntexb_(at)_gmail.com, Kerberos Version 1.5.1 Kadmind Remote Root Buffer Overflow Vulnerability (11.04.2007)
 documentMIT, MITKRB5-SA-2007-002: KDC, kadmind stack overflow in krb5_klog_syslog [CVE-2007-0957] (04.04.2007)
 documentMIT, MITKRB5-SA-2007-003: double-free vulnerability in kadmind (via GSS-API library) [CVE-2007-1216] (04.04.2007)
 documentMIT, MITKRB5-SA-2007-001: telnetd allows login as arbitrary user [CVE-2007-0956] (04.04.2007)
 documentIDEFENSE, iDefense Security Advisory 04.03.07: Multiple Vendor Kerberos kadmind Buffer Overflow Vulnerability (04.04.2007)
 documentCERT, US-CERT Technical Cyber Security Alert TA07-093B -- MIT Kerberos Vulnerabilities (04.04.2007)
Files:Exploits Kerberos 1.5.1 Kadmind Remote Root Buffer Overflow Vulnerability

About | Terms of use | Privacy Policy
© SecurityVulns, 3APA3A, Vladimir Dubrovin
Nizhny Novgorod