Computer Security
[EN] securityvulns.ru no-pyccku


OpenVPN cryptography weakness
Published:05.06.2013
Source:
SecurityVulns ID:13114
Type:m-i-t-m
Threat Level:
7/10
Description:It's possible to inject and decript ciphertext in UDP mode.
Affected:OPENVPN : OpenVPN 2.2
CVE:CVE-2013-2061 (The openvpn_decrypt function in crypto.c in OpenVPN 2.3.0 and earlier, when running in UPD mode, allows remote attackers to obtain sensitive information via a timing attack involving an HMAC comparison function that does not run in constant time and a padding oracle attack on the CBC mode cipher.)
Original documentdocumentMANDRIVA, [ MDVSA-2013:167 ] openvpn (05.06.2013)

About | Terms of use | Privacy Policy
© SecurityVulns, 3APA3A, Vladimir Dubrovin
Nizhny Novgorod