Computer Security
[EN] securityvulns.ru no-pyccku


Qt format string vulnerabilities
Published:03.08.2007
Source:
SecurityVulns ID:7999
Type:library
Threat Level:
6/10
Description:Multiple format string vulnerabilities on format string bugs.
Affected:QT : qt 3.3
CVE:CVE-2007-3388 (Multiple format string vulnerabilities in (1) qtextedit.cpp, (2) qdatatable.cpp, (3) qsqldatabase.cpp, (4) qsqlindex.cpp, (5) qsqlrecord.cpp, (6) qglobal.cpp, and (7) qsvgdevice.cpp in QTextEdit in Trolltech Qt 3 before 3.3.8 20070727 allow remote attackers to execute arbitrary code via format string specifiers in text used to compose an error message.)
Original documentdocumentRPATH, rPSA-2007-0153-1 qt-x11-free (03.08.2007)
 documentMANDRIVA, [ MDKSA-2007:151 ] - Updated qt3 packages fix multiple vulnerabilities (03.08.2007)

About | Terms of use | Privacy Policy
© SecurityVulns, 3APA3A, Vladimir Dubrovin
Nizhny Novgorod