Computer Security
[EN] securityvulns.ru no-pyccku


Sketchup multiple security vulnerabilities
Published:03.06.2013
Source:
SecurityVulns ID:13098
Type:local
Threat Level:
3/10
Description:Vulnerabilities on SKP, BMP, PICT parsing.
Affected:SKETCHUP : SketchUp 8.0
CVE:CVE-2013-3664 (Trimble SketchUp (formerly Google SketchUp) before 2013 (13.0.3689) allows remote attackers to execute arbitrary code via a crafted color palette table in a MAC Pict texture, which triggers an out-of-bounds stack write. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-3662. NOTE: this issue was SPLIT due to different affected products and codebases (ADT1); CVE-2013-7388 has been assigned to the paintlib issue.)
 CVE-2013-3663 (Heap-based buffer overflow in paintlib, as used in Trimble SketchUp (formerly Google SketchUp) before 8 Maintenance 3, allows remote attackers to execute arbitrary code via a crafted RLE8 compressed BMP.)
 CVE-2013-3662 (Timbre SketchUp (formerly Google SketchUp) before 8 Maintenance 2 allows remote attackers to execute arbitrary code via a crafted color palette table in a MAC Pict texture, which triggers a stack-based buffer overflow.)
Original documentdocumentFelipe Manzano, CVE-2013-3662 - Sketchup MAC Pict Material Palette Stack Corruption (03.06.2013)
 documentFelipe Manzano, CVE-2013-3663 - SketchUp BMP RLE8 Heap Overflow (03.06.2013)
 documentFelipe Manzano, CVE-2013-3664 - Sketchup Multiple Vulnerabilities (03.06.2013)

About | Terms of use | Privacy Policy
© SecurityVulns, 3APA3A, Vladimir Dubrovin
Nizhny Novgorod