Computer Security
[EN] securityvulns.ru no-pyccku


Trend Micro Antivirus multiple security vulnerabilities
updated since 08.02.2007
Published:11.02.2007
Source:
SecurityVulns ID:7200
Type:remote
Threat Level:
5/10
Description:Buffer overflow on UPX-packed executables parsing. Privilege escalation through \\.\TmComm DOS-device.
Affected:TM : PC-Cillin Internet Security 2007
 TM : Trend Micro ServerProtect for Linux 2.5
 TM : Trend Micro AntiVirus 2007
 TM : Trend Micro Anti-Spyware for SMB 3.2
 TM : Trend Micro Anti-Spyware for Enterprise 3.0
 TM : Trend Micro Anti-Spyware for Consumer 3.5
CVE:CVE-2007-0856 (TmComm.sys 1.5.0.1052 in the Trend Micro Anti-Rootkit Common Module (RCM), with the VsapiNI.sys 3.320.0.1003 scan engine, as used in Trend Micro PC-cillin Internet Security 2007, Antivirus 2007, Anti-Spyware for SMB 3.2 SP1, Anti-Spyware for Consumer 3.5, Anti-Spyware for Enterprise 3.0 SP2, Client / Server / Messaging Security for SMB 3.5, Damage Cleanup Services 3.2, and possibly other products, assigns Everyone write permission for the \\.\TmComm DOS device interface, which allows local users to access privileged IOCTLs and execute arbitrary code or overwrite arbitrary memory in the kernel context.)
 CVE-2007-0851 (Buffer overflow in the Trend Micro Scan Engine 8.000 and 8.300 before virus pattern file 4.245.00, as used in other products such as Cyber Clean Center (CCC) Cleaner, allows remote attackers to execute arbitrary code via a malformed UPX compressed executable.)
Original documentdocumentReversemode, [Reversemode Advisory] TrendMicro Products - multiple privilege escalation vulnerabilities. (11.02.2007)
 documentIDEFENSE, iDefense Security Advisory 02.07.07: Trend Micro TmComm Local Privilege Escalation Vulnerability (08.02.2007)

About | Terms of use | Privacy Policy
© SecurityVulns, 3APA3A, Vladimir Dubrovin
Nizhny Novgorod