Computer Security
[EN] securityvulns.ru no-pyccku


VLC media player multiple security vulnerabilities
Published:22.06.2007
Source:
SecurityVulns ID:7839
Type:client
Threat Level:
5/10
Description:Format string vulnerabilities in Ogg Vorbis and Ogg Theora comments parsing, CDDA data, SAP/SDP discovery service. Integer overflow and uninitialized variables on WAV parsing.
Affected:VLC : VLC 0.8
CVE:CVE-2007-3467 (Integer overflow in the __status_Update function in stats.c VideoLAN VLC Media Player before 0.8.6c allows remote attackers to cause a denial of service (crash) via a WAV file with a large sample rate.)
 CVE-2007-3316 (Multiple format string vulnerabilities in plugins in VideoLAN VLC Media Player before 0.8.6c allow remote attackers to cause a denial of service (crash) or execute arbitrary code via format string specifiers in (1) an Ogg/Vorbis file, (2) an Ogg/Theora file, (3) a CDDB entry for a CD Digital Audio (CDDA) file, or (4) Service Announce Protocol (SAP) multicast packets.)
Original documentdocumentDavid Thiel, VLC 0.8.6b format string vulnerability & integer overflow (22.06.2007)

About | Terms of use | Privacy Policy
© SecurityVulns, 3APA3A, Vladimir Dubrovin
Nizhny Novgorod