Computer Security
[EN] securityvulns.ru no-pyccku


dbus privilege escalation
Published:04.10.2012
Source:
SecurityVulns ID:12614
Type:local
Threat Level:
5/10
Description:Privilege escalation via environment variables.
Affected:DBUS : dbus 1.5
CVE:CVE-2012-3524 (libdbus 1.5.x and earlier, when used in setuid or other privileged programs in X.org and possibly other products, allows local users to gain privileges and execute arbitrary code via the DBUS_SYSTEM_BUS_ADDRESS environment variable. NOTE: libdbus maintainers state that this is a vulnerability in the applications that do not cleanse environment variables, not in libdbus itself: "we do not support use of libdbus in setuid binaries that do not sanitize their environment before their first call into libdbus.")
Original documentdocumentUBUNTU, [USN-1576-1] DBus vulnerability (04.10.2012)

About | Terms of use | Privacy Policy
© SecurityVulns, 3APA3A, Vladimir Dubrovin
Nizhny Novgorod