Computer Security
[EN] securityvulns.ru no-pyccku


gif2png buffer overflow
Published:19.01.2011
Source:
SecurityVulns ID:11365
Type:library
Threat Level:
5/10
Description:Buffer overflow on GIF processing.
Affected:GIF2PNG : gif2png 2.5
CVE:CVE-2010-4694 (Buffer overflow in gif2png.c in gif2png 2.5.3 and earlier might allow context-dependent attackers to cause a denial of service (application crash) or have unspecified other impact via a GIF file that contains many images, leading to long extensions such as .p100 for PNG output files, as demonstrated by a CGI program that launches gif2png, a different vulnerability than CVE-2009-5018.)
 CVE-2009-5018 (Stack-based buffer overflow in gif2png.c in gif2png 2.5.3 and earlier might allow context-dependent attackers to execute arbitrary code via a long command-line argument, as demonstrated by a CGI program that launches gif2png.)
Original documentdocumentMANDRIVA, [ MDVSA-2011:009 ] gif2png (19.01.2011)

About | Terms of use | Privacy Policy
© SecurityVulns, 3APA3A, Vladimir Dubrovin
Nizhny Novgorod