Computer Security
[EN] securityvulns.ru no-pyccku


libESMTP SSL vulnerabilities
Published:08.10.2010
Source:
SecurityVulns ID:11184
Type:library
Threat Level:
5/10
Description:It's possible to spoof certificate by different ways.
Affected:LIBESMTP : libESMTP 1.0.
CVE:CVE-2010-1194 (The match_component function in smtp-tls.c in libESMTP 1.0.3.r1, and possibly other versions including 1.0.4, treats two strings as equal if one is a substring of the other, which allows remote attackers to spoof trusted certificates via a crafted subjectAltName.)
 CVE-2010-1192 (libESMTP, probably 1.0.4 and earlier, does not properly handle a '\0' character in a domain name in the subject's Common Name (CN) field of an X.509 certificate, which allows man-in-the-middle attackers to spoof arbitrary SSL servers via a crafted certificate issued by a legitimate Certification Authority, a related issue to CVE-2009-2408.)
Original documentdocumentMANDRIVA, [ MDVSA-2010:195 ] libesmtp (08.10.2010)

About | Terms of use | Privacy Policy
© SecurityVulns, 3APA3A, Vladimir Dubrovin
Nizhny Novgorod