Computer Security
[EN] securityvulns.ru no-pyccku


libgdiplus / Mono multiple integer overflows
Published:02.09.2010
Source:
SecurityVulns ID:11111
Type:library
Threat Level:
5/10
Description:Multiple integer overflows on BPM, JPEG, TIFF parsing.
Affected:LIBGDIPLUS : libgdiplus 2.6
CVE:CVE-2010-1526 (Multiple integer overflows in libgdiplus 2.6.7, as used in Mono, allow attackers to execute arbitrary code via (1) a crafted TIFF file, related to the gdip_load_tiff_image function in tiffcodec.c; (2) a crafted JPEG file, related to the gdip_load_jpeg_image_internal function in jpegcodec.c; or (3) a crafted BMP file, related to the gdip_read_bmp_image function in bmpcodec.c, leading to heap-based buffer overflows.)
Original documentdocumentMANDRIVA, [ MDVSA-2010:166 ] libgdiplus (02.09.2010)

About | Terms of use | Privacy Policy
© SecurityVulns, 3APA3A, Vladimir Dubrovin
Nizhny Novgorod