Computer Security
[EN] securityvulns.ru no-pyccku


libpng code execution
updated since 01.05.2008
Published:13.05.2008
Source:
SecurityVulns ID:8959
Type:library
Threat Level:
7/10
Affected:libpng : libpng 1.2
 PNGCRUSH : pngcrush 1.6
 libpng : libpng 1.4
 POVRAY : POV-Ray 3.6
CVE:CVE-2008-3964 (Multiple off-by-one errors in libpng before 1.2.32beta01, and 1.4 before 1.4.0beta34, allow context-dependent attackers to cause a denial of service (crash) or have unspecified other impact via a PNG image with crafted zTXt chunks, related to (1) the png_push_read_zTXt function in pngread.c, and possibly related to (2) pngtest.c.)
 CVE-2008-1382
Original documentdocumentGENTOO, [ GLSA 200805-10 ] Pngcrush: User-assisted execution of arbitrary code (13.05.2008)
 documentRPATH, rPSA-2008-0151-1 libpng (01.05.2008)

About | Terms of use | Privacy Policy
© SecurityVulns, 3APA3A, Vladimir Dubrovin
Nizhny Novgorod