Computer Security
[EN] securityvulns.ru no-pyccku


libtiff buffer overflow
Published:23.03.2011
Source:
SecurityVulns ID:11522
Type:library
Threat Level:
6/10
Description:Buffer overflow in ThunderCode codec, stack overflow.
Affected:LIBTIFF : libtiff 6.9
CVE:CVE-2011-1167 (Heap-based buffer overflow in the thunder (aka ThunderScan) decoder in tif_thunder.c in LibTIFF 3.9.4 and earlier allows remote attackers to execute arbitrary code via crafted THUNDER_2BITDELTAS data in a .tiff file that has an unexpected BitsPerSample value.)
Original documentdocumentzgmzgm_(at)_mail.ustc.edu.cn, Buffer overflow in libtiff in Imagemagick (23.03.2011)
 documentZDI, ZDI-11-107: Libtiff ThunderCode Decoder THUNDER_2BITDELTAS Remote Code Execution Vulnerability (23.03.2011)

About | Terms of use | Privacy Policy
© SecurityVulns, 3APA3A, Vladimir Dubrovin
Nizhny Novgorod