Computer Security
[EN] securityvulns.ru no-pyccku


libxalan security vulnerabilities
Published:27.03.2014
Source:
SecurityVulns ID:13630
Type:library
Threat Level:
5/10
Description:Information leak, code execution.
Affected:XALAN : libxalan 2.7
CVE:CVE-2014-0107 (The TransformerFactory in Apache Xalan-Java before 2.7.2 does not properly restrict access to certain properties when FEATURE_SECURE_PROCESSING is enabled, which allows remote attackers to bypass expected restrictions and load arbitrary classes or access external resources via a crafted (1) xalan:content-header, (2) xalan:entities, (3) xslt:content-header, or (4) xslt:entities property, or a Java property that is bound to the XSLT 1.0 system-property function.)
Original documentdocumentAndrea Barisani, [oCERT-2014-002] Xalan-Java insufficient secure processing (27.03.2014)
 documentDEBIAN, [SECURITY] [DSA 2886-1] libxalan2-java security update (27.03.2014)

About | Terms of use | Privacy Policy
© SecurityVulns, 3APA3A, Vladimir Dubrovin
Nizhny Novgorod