Computer Security
[EN] securityvulns.ru no-pyccku


libxslt multiple security vulnerabilities
Published:01.08.2008
Source:
SecurityVulns ID:9185
Type:library
Threat Level:
6/10
Description:Heap buffer overflow, invalid digital signature check.
Affected:LIBXSLT : libxslt 1.1
CVE:CVE-2008-2935 (Multiple heap-based buffer overflows in the rc4 (1) encryption (aka exsltCryptoRc4EncryptFunction) and (2) decryption (aka exsltCryptoRc4DecryptFunction) functions in crypto.c in libexslt in libxslt 1.1.8 through 1.1.24 allow context-dependent attackers to execute arbitrary code via an XML file containing a long string as "an argument in the XSL input.")
Original documentdocumentAndrea Barisani, [oCERT-2008-009] libxslt heap overflow (01.08.2008)

About | Terms of use | Privacy Policy
© SecurityVulns, 3APA3A, Vladimir Dubrovin
Nizhny Novgorod