Computer Security
[EN] securityvulns.ru no-pyccku


perl Crypt::DSA weak PRNG generator
Published:02.10.2013
Source:
SecurityVulns ID:13305
Type:library
Threat Level:
5/10
Description:Under some conditions, weak PRNG generator is used.
Affected:PERL : Crypt::DSA 1.17
CVE:CVE-2011-3599 (The Crypt::DSA (aka Crypt-DSA) module 1.17 and earlier for Perl, when /dev/random is absent, uses the Data::Random module, which makes it easier for remote attackers to spoof a signature, or determine the signing key of a signed message, via a brute-force attack.)
Original documentdocumentMANDRIVA, [ MDVSA-2013:241 ] perl-Crypt-DSA (02.10.2013)

About | Terms of use | Privacy Policy
© SecurityVulns, 3APA3A, Vladimir Dubrovin
Nizhny Novgorod