Computer Security
[EN] securityvulns.ru
no-pyccku



PHP security vulnerabilities
Published:30.07.2012
Source:BUGTRAQ
SecurityVulns ID:12495
Type:library
Level:5/10
Description:_php_stream_scandir overflow, SQLite functionality open_basedir protection bypass.
Affected:PHP : PHP 5.3
 PHP : PHP 5.4
CVE:CVE-2012-3450 (pdo_sql_parser.re in the PDO extension in PHP before 5.3.14 and 5.4.x before 5.4.4 does not properly determine the end of the query string during parsing of prepared statements, which allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via a crafted parameter value.)
 CVE-2012-3365 (The SQLite functionality in PHP before 5.3.15 allows remote attackers to bypass the open_basedir protection mechanism via unspecified vectors.)
 CVE-2012-2688 (Unspecified vulnerability in the _php_stream_scandir function in the stream implementation in PHP before 5.3.15 and 5.4.x before 5.4.5 has unknown impact and remote attack vectors, related to an "overflow.")
Original documentdocumentMANDRIVA, [ MDVSA-2012:108 ] php (30.07.2012)
Discuss:Read or add your comments to this news (0 comments)

About | Terms of use | Privacy Policy
© SecurityVulns, 3APA3A, Vladimir Dubrovin
Nizhny Novgorod

 
 



Rating@Mail.ru