Computer Security
[EN] securityvulns.ru no-pyccku


stunnel crypto vulnerabilities
Published:20.04.2015
Source:
SecurityVulns ID:14417
Type:remote
Threat Level:
5/10
Description:Entropy pools are reused if fork() if used for threading.
Affected:STUNNEL : stunnel 4.0
CVE:CVE-2014-0016 (stunnel before 5.00, when using fork threading, does not properly update the state of the OpenSSL pseudo-random number generator (PRNG), which causes subsequent children with the same process ID to use the same entropy pool and allows remote attackers to obtain private keys for EC (ECDSA) or DSA certificates.)
Original documentdocumentMANDRIVA, [ MDVSA-2015:096 ] stunnel (20.04.2015)

About | Terms of use | Privacy Policy
© SecurityVulns, 3APA3A, Vladimir Dubrovin
Nizhny Novgorod