Computer Security
[EN] securityvulns.ru no-pyccku


OpenSSL restrictions bypass
Published:09.07.2015
Source:
SecurityVulns ID:14572
Type:library
Threat Level:
8/10
Description:Certificate without CA flag can be validated as a valid signing certificate.
CVE:CVE-2015-1793 (The X509_verify_cert function in crypto/x509/x509_vfy.c in OpenSSL 1.0.1n, 1.0.1o, 1.0.2b, and 1.0.2c does not properly process X.509 Basic Constraints cA values during identification of alternative certificate chains, which allows remote attackers to spoof a Certification Authority role and trigger unintended certificate verifications via a valid leaf certificate.)
Files:OpenSSL Security Advisory [9 Jul 2015] Alternative chains certificate forgery (CVE-2015-1793)

About | Terms of use | Privacy Policy
© SecurityVulns, 3APA3A, Vladimir Dubrovin
Nizhny Novgorod