Computer Security
[EN] securityvulns.ru no-pyccku


Linux kernel multiple security vulnerabilities
Published:11.12.2009
Source:
SecurityVulns ID:10464
Type:remote
Threat Level:
7/10
Description:Crash on malformed IP packet defragmentation, privilege escalation with Ext4 "move extents" ioctl.
Affected:LINUX : kernel 2.6
CVE:CVE-2009-4131 (The EXT4_IOC_MOVE_EXT (aka move extents) ioctl implementation in the ext4 filesystem in the Linux kernel before 2.6.32-git6 allows local users to overwrite arbitrary files via a crafted request, related to insufficient checks for file permissions.)
 CVE-2009-1298 (The ip_frag_reasm function in net/ipv4/ip_fragment.c in the Linux kernel 2.6.32-rc8, and 2.6.29 and later versions before 2.6.32, calls IP_INC_STATS_BH with an incorrect argument, which allows remote attackers to cause a denial of service (NULL pointer dereference and hang) via long IP packets, possibly related to the ip_defrag function.)
Original documentdocumentUBUNTU, [USN-869-1] Linux kernel vulnerabilities (11.12.2009)

About | Terms of use | Privacy Policy
© SecurityVulns, 3APA3A, Vladimir Dubrovin
Nizhny Novgorod